华为S5720系列交换机快速配置手册常用命令

Posted by Sunday on 2018-12-26

华为交换机常用视图:用户视图,系统视图

用户视图:刚开始登入交换机时的视图,一般看到的是尖括号<>
1
2
3
4
5
6
save                                // 配置完交换机后保存当前配置的命令
system-view // 进入系统视图的命令
clock timezone BJ add|minus 8 // 设置时区
clock datetime 16:36:00 2020-07-01 // 设置交换机的时间
dis cu // 显示当前配置
dis cu int // 显示当前接口配置
系统视图: 在用户视图下输入system-view后进入系统视图,一般为方括号[]
1
2
3
4
sysname xxxx                                       //修改交换机设备名,不支持中文
user-interface console 0 //进入第0个console口的用户界面
authentication-mode passwd //配置从console口登入交换机的认证模式为密码认证
set authentication password cipher admin@123 //配置从console口登入交换机的密码

例子(都在系统视图进行配置):

1、开启SSH登陆交换机

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
#1、创建本地密钥对
rsa local-key-pair create
#2、检查是否存在SSH user(可跳过),系统提示没有SSH user 存在
dis ssh user-information
#3、创建SSH user
ssh user xxx authentication-type password
创建名为xxx的用户,认证模式为密码认证
ssh user xxx service-type stelnet
服务类型为stelnet,即SSH
#4、创建用户
aaa
进入aaa
local-user xxx password cipher 12345678
创建对应的SSH用户名,12345678为你想要设置的密码
local-user xxx privilege level 3
设置用户登记,用户level最高到15
local-user xxx service-type ssh
开启该用户允许使用SSH访问设备的权限
#5、启用SSH(stelnet)服务
stelnet server enable
#6、配置vty界面支持的登录协议
user-interface vty 0 4
authentication-mode aaa
protocol inbound ssh

2、创建VLAN,设置管理IP和DNS,配置默认路由

1
2
3
4
5
6
7
8
9
10
11
12
vlan batch  1 to 2 10 100
批量创建VLAN1、2、10、100
interface vlan 2
进入VLAN2
ip address 172.16.0.1 255.255.255.0
设置管理IP
dns server 223.5.5.5
dns server 114.114.114.114
dns domain itca.cc
设置DNS
ip route-static 0.0.0.0 0.0.0.0 172.10.0.1
配置所有网络到达所有网络的路径都是由这个172.10.0.1这个地址的接口负责传送

ip route-static 192.168.1.0 255.255.255.0 192.168.0.2是设置静态路由,其中192.168.1.0意思是指信息要传到的目的地的ip地址,255.255.255.0为其对应的子网掩码,192.168.0.2表示信息要达到目的地所要经过的下一个路由器的端口IP地址。

3、配置Trunk口,配置端口VLAN

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
interface gigabitethernet 0/0/24
进入第24个网络端口
port link-type trunk
设置该端口为Trunk模式
port trunk allow-pass vlan 1 to 2
穿透VLAN1、2
interface gigabitethernet 0/0/1
进入第1个网络端口
port default vlan 1
设置该端口为VLAN1
port default vlan
恢复该端口的VLAN缺省值

display port vlan
显示当前各端口的VLAN情况

4、批量配置交换机端口

1
2
3
4
5
6
7
8
port-group 1
创建组号为1的端口组
group-member gigabitethernet 0/0/1 to gigabitethernet 0/0/10
110号网络端口加入端口组
port link-type access
批量设置端口为Access模式
port default vlan 10
批量设置端口为VLAN10

5、清除某个端口的配置,启动端口

1
2
3
4
5
6
7
8
interface gigabitethernet 0/0/2
打开第2个网络接口
Clear configuration this
清理该端口全部配置信息
Undo shutdown
启动端口
shutdown
关闭端口

6、恢复出厂设置及重启

1
2
3
4
5
6
7
reset saved-configuration
Y
恢复出厂,输入y确定恢复
Reboot
N
Y
重启设备,第一次输入n不保存配置,第二次输入y确定重启

7、配置Eth-Trunk链路聚合

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
1)手工模式
SW1配置(SW2类似)
interface Eth-Trunk1
port link-type trunk
undo port trunk allow-pass vlan 1
port trunk allow-pass vlan 10 20
interface GigabitEthernet0/0/1
eth-trunk 1
interface GigabitEthernet0/0/2
eth-trunk 1
2)LACP模式
SW1配置(SW2类似)
interface Eth-Trunk1
port link-type trunk
undo port trunk allow-pass vlan 1
port trunk allow-pass vlan 10 20
mode lacp-static //配置模式为静态LACP
max active-linknumber 1 //配置活动接口数量(默认活动接口数量为8,此处两条线路一条为主,一条为备。通信是只有活动接口转发数据)
//注:配置完Eth-Trunk之后再加入接口,LACP模式适用与两台设备多条线路互联,可选择其中几条为主,剩余线路为备,线路故障后备线路自动补上,期间业务影响较小
interface GigabitEthernet0/0/1
eth-trunk 1
interface GigabitEthernet0/0/2
eth-trunk 1

8、配置开启SNMPv2

1
2
3
4
5
6
7
8
snmp-agent community read  public                    // 设置读团体名:public,高版本有复杂度要求
snmp-agent community write private // 设置写团体名:private
snmp-agent sys-info version v1 v2c // 配置SNMP版本 (v1和v2)
snmp-agent sys-info contact ITCA:10086 // 设置联系方式
snmp-agent sys-info location 3rd-flood // 设置设备位置
snmp-agent trap enable
snmp-agent target-host trap address udp-domain 192.168.1.10 params securityname public
// 允许向网管工作站(NMS)192.168.1.10发送Trap报文,使用的团体名为public

https://support.huawei.com/enterprise/zh/doc/EDOC1000178160/40dfdfef